Sabtu, 23 April 2011

MPLS

Multi Protocol Labeling Switching

P = Provider Edge
PE = Provider Edge
CE = Customer Edge

Topology Sederhana PE PE:

R1#sh mpls interfaces
Interface IP Tunnel Operational
FastEthernet0/0 Yes (ldp) No Yes

R2#sh mpls interfaces
Interface IP Tunnel Operational
FastEthernet0/0 Yes (ldp) No Yes

R1

no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf BCA
rd 12:2
route-target export 12:2
route-target import 12:2
!
ip vrf BRI
rd 12:1
route-target export 12:1
route-target import 12:1
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback11
ip vrf forwarding BRI
ip address 10.10.10.1 255.255.255.255
!
interface Loopback12
ip vrf forwarding BCA
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf BRI
redistribute connected
no synchronization
exit-address-family
!
address-family ipv4 vrf BCA
redistribute connected
no synchronization
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane


R2

no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf BCA
rd 12:2
route-target export 12:2
route-target import 12:2
!
ip vrf BRI
rd 12:1
route-target export 12:1
route-target import 12:1
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback11
ip vrf forwarding BRI
ip address 10.10.10.2 255.255.255.255
!
interface Loopback12
ip vrf forwarding BCA
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf BRI
redistribute connected
no synchronization
exit-address-family
!
address-family ipv4 vrf BCA
redistribute connected
no synchronization
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane

Tidak ada komentar: