Minggu, 24 April 2011

MPLS + RIP customer & PE

Topology untuk MPLS di cust menggunakan RIP:

CUST(rip) CE----------PE1------PE2------CE (CUST(rip)

berikut konfigurasi di PE1:


di PE1:
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf BTN
rd 12:2
route-target export 12:2
route-target import 12:2
!
ip vrf NIAGA
rd 12:1
route-target export 12:1
route-target import 12:1
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding BTN
ip address 16.16.16.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip vrf forwarding NIAGA
ip address 15.15.15.1 255.255.255.0
speed auto
half-duplex
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0
!
router rip
version 2
!
address-family ipv4 vrf BTN
redistribute bgp 12 metric transparent
network 16.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 12
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf NIAGA
redistribute connected
no synchronization
exit-address-family
!
address-family ipv4 vrf BTN
redistribute connected
redistribute rip
no synchronization
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane

Konfigurasi di PE2 :

no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf BTN
rd 12:2
route-target export 12:2
route-target import 12:2
!
ip vrf NIAGA
rd 12:1
route-target export 12:1
route-target import 12:1
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding NIAGA
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip vrf forwarding BTN
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0
!
router rip
version 2
no auto-summary
!
address-family ipv4 vrf BTN
redistribute bgp 12 metric transparent
network 24.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 12
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf NIAGA
redistribute connected
no synchronization
exit-address-family
!
address-family ipv4 vrf BTN
redistribute connected
redistribute rip
no synchronization
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
mpls ldp router-id Loopback0
!
!
control-plane

konfigurasi di cust :
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 16.16.16.6 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 16.0.0.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane

Konfigurasi di cust 2:


hostname btn-medan
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 24.24.24.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 24.0.0.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane

Kesimpulan :

Lakukan redistribute mutual di kedua routing (bgp <=> MPLS)
di rip dengan metric transparent, dan bgp dengan redistribute rip biasa.
sh ip vrf BTN --> akan muncul loopback dari RIP customer begitu juga di cust.

contoh show di cust:
BTN-JAKARTA#SH IP ROute
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

16.0.0.0/24 is subnetted, 1 subnets
C 16.16.16.0 is directly connected, FastEthernet0/0
24.0.0.0/24 is subnetted, 1 subnets
R 24.24.24.0 [120/1] via 16.16.16.1, 00:00:14, FastEthernet0/0 --> rip dari cust sebrangnya.


...LANJUTAN..

Tidak ada komentar: