Kamis, 27 Oktober 2011

IPS on GNS

hehe, akhirnya bisa juga mencoba IPS di gns gw cek this out :

jre 1.5 update 6

http://rapidshare.com/files/170067128/jre-6u7-windows-i586-p-s.zip

Kamis, 13 Oktober 2011

OeR / Pfr



Optimized edge Routing, di cisco ini disebut Pfr. Salah satu cara memindahkan link dengan adanya collision di jaringan yang dilalui oleh data nantinya.

conf R1 :

hostname R1
!
boot-start-marker
boot-end-marker
!
!
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
key chain KC_OER
key 1
key-string CISCO
!
!
oer master
logging
!
border 150.1.2.2 key-chain KC_OER
interface FastEthernet0/1 internal
interface FastEthernet0/0 external
!
border 150.1.3.3 key-chain KC_OER
interface FastEthernet0/1 internal
interface FastEthernet0/0 external
!
learn
throughput
delay
periodic-interval 1
monitor-period 2
aggregation-type prefix-length 32
no max range receive
backoff 90 180
mode route control
mode route metric static tag 777
mode select-exit best
resolve delay priority 1 variance 1
resolve utilization priority 2 variance 1
resolve loss priority 3 variance 1
resolve range priority 4
!
!
!
!
!
username admin privilege 15 password 0 admin
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 150.1.1.1 255.255.255.0
ip flow monitor MYMONITOR input
!
interface FastEthernet0/0
ip address 155.1.12.1 255.255.255.0
ip flow monitor MYMONITOR input
duplex a
*Mar 1 01:39:39.475: %OER_MC-5-NOTICE: Range OOP BR 150.1.2.2, i/f Fa0/0, percent 100
*Mar 1 01:39:39.479: %OER_MC-5-NOTICE: Load OOP BR 150.1.2.2, i/f Fa0/0, load 0 policy 5
*Mar 1 01:39:39.479: %OER_MC-5-NOTICE: Exit 150.1.2.2 intf Fa0/0 OOP, Tx BW 5, Rx BW 0, Tx Load 100, Rx Load 0uto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 155.1.13.1 255.255.255.0
ip flow monitor MYMONITOR input
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 150.1.1.1 0.0.0.0 area 0
network 155.1.12.1 0.0.0.0 area 0
network 155.1.13.1 0.0.0.0 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ip sla 1
udp-jitter 4.2.2.2 17000 source-ip 150.1.1.1 source-port 17000 codec g729a
timeout 700
frequency 1
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 100.100.100.100 source-interface Loopback0
timeout 900
frequency 1
ip sla schedule 2 life forever start-time now
ip sla 3
tcp-connect 200.200.200.200 5000 source-ip 150.1.1.1
timeout 1500
frequency 2
ip sla schedule 3 life forever start-time now
!
!
!
!
!
!
control-plane


R2 :

hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
key chain KC_OER
key 1
key-string CISCO
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
oer border
logging
local Loopback0
master 150.1.1.1 key-chain KC_OER
active-probe address source interface Loopback0
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 150.1.2.2 255.255.255.0
!
interface FastEthernet0/0
bandwidth 5
ip address 222.165.222.73 255.255.255.248
delay 1000000
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 155.1.12.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
redistribute static metric-type 1 subnets
network 150.1.2.2 0.0.0.0 area 0
network 155.1.12.2 0.0.0.0 area 0
network 222.165.222.73 0.0.0.0 area 0
default-information originate metric-type 1
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 222.165.222.78

R3 :

hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
key chain KC_OER
key 1
key-string CISCO
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
oer border
logging
local Loopback0
master 150.1.1.1 key-chain KC_OER
active-probe address source interface Loopback0
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 150.1.3.3 255.255.255.0
!
interface FastEthernet0/0
bandwidth 512
ip address 202.72.212.180 255.255.255.240
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 155.1.13.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
redistribute static metric-type 1 subnets
network 150.1.3.3 0.0.0.0 area 0
network 155.1.13.3 0.0.0.0 area 0
network 202.72.212.180 0.0.0.0 area 0
default-information originate metric-type 1
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 202.72.212.177


ISP :

hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
archive
log config
hidekeys
!
!
interface FastEthernet0/0
ip address 222.165.222.78 255.255.255.248
duplex auto
speed auto
!
interface Serial0/0
bandwidth 128
ip address 200.1.1.0 255.255.255.254
clock rate 128000
!
interface FastEthernet0/1
ip address 202.72.212.177 255.255.255.240
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
version 2
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 200.1.1.0
network 202.72.212.0
network 222.165.222.0
default-information originate
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 222.165.222.73
ip route 0.0.0.0 0.0.0.0 202.72.212.180


Router INET :

hostname INET
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
archive
log config
hidekeys
!
!
interface Loopback0
ip address 100.100.100.100 255.255.255.255
!
interface Loopback1
ip address 200.200.200.200 255.255.255.255
!
interface Loopback2
ip address 4.2.2.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
bandwidth 128
ip address 200.1.1.1 255.255.255.254
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
version 2
network 4.0.0.0
network 100.0.0.0
network 200.1.1.0
network 200.200.200.0
no auto-summary
!
ip forward-protocol nd



---------------------------------

Result :

*Mar 1 01:44:33.563: %OER_MC-5-NOTICE: BR 150.1.3.3 IF Fa0/1 Admin Down
*Mar 1 01:44:33.563: %OER_MC-5-NOTICE: BR 150.1.3.3 Inactive
*Mar 1 01:44:33.567: %OER_MC-5-NOTICE: Uncontrol prefixes, Clear exit, BR 150.1.3.3 i/f Fa0/0
*Mar 1 01:44:37.991: %OER_MC-5-NOTICE: BR 150.1.3.3 IF Fa0/1 UP
*Mar 1 01:44:37.991: %OER_MC-5-NOTICE: BR 150.1.3.3 Active
*Mar 1 01:44:38.003: %OER_MC-5-NOTICE: BR 150.1.3.3 DOWN
*Mar 1 01:44:38.003: %OER_MC-5-NOTICE: BR 150.1.3.3 IF Fa0/1 Unverified
*Mar 1 01:44:38.007: %OER_MC-5-NOTICE: BR 150.1.3.3 IF Fa0/0 Unverified
*Mar 1 01:44:38.011: %OER_MC-5-NOTICE: Uncontrol prefixes, Clear exit, BR 150.1.3.3 i/f Fa0/0
*Mar 1 01:44:38.031: %OER_MC-5-NOTICE: Uncontrol prefixes, Exit down, BR 150.1.3.3 i/f Fa0/0
*Mar 1 01:44:41.031: %OER_MC-5-NOTICE: BR 150.1.2.2 UP
*Mar 1 01:44:41.211: %OER_MC-5-NOTICE: BR 150.1.2.2 IF Fa0/1 UP
*Mar 1 01:44:41.391: %OER_MC-5-NOTICE: BR 150.1.2.2 IF Fa0/0 UP
*Mar 1 01:44:41.395: %OER_MC-5-NOTICE: BR 150.1.2.2 Active
*Mar 1 01:44:42.847: %OER_MC-5-NOTICE: BR 150.1.3.3 UP
*Mar 1 01:44:43.359: %OER_MC-5-NOTICE: BR 150.1.3.3 IF Fa0/1 UP
*Mar 1 01:44:43.579: %OER_MC-5-NOTICE: BR 150.1.3.3 IF Fa0/0 UP
*Mar 1 01:44:43.583: %OER_MC-5-NOTICE: BR 150.1.3.3 Active
*Mar 1 01:44:43.587: %OER_MC-5-NOTICE: MC Active

untuk router 2 :

*Mar 1 01:45:28.283: %OER_MC-5-NOTICE: BR 150.1.2.2 UP
*Mar 1 01:45:28.455: %OER_MC-5-NOTICE: BR 150.1.2.2 IF Fa0/1 UP
*Mar 1 01:45:28.683: %OER_MC-5-NOTICE: BR 150.1.2.2 IF Fa0/0 UP
*Mar 1 01:45:28.687: %OER_MC-5-NOTICE: BR 150.1.2.2 Active
*Mar 1 01:45:28.687: %OER_MC-5-NOTICE: MC Active

R1#sh oer master
OER state: ENABLED and ACTIVE
Conn Status: SUCCESS, PORT: 3949
Version: 2.1
Number of Border routers: 2
Number of Exits: 2
Number of monitored prefixes: 0 (max 5000)
Max prefixes: total 5000 learn 2500
Prefix count: total 0, learn 0, cfg 0

Border Status UP/DOWN AuthFail Version
150.1.3.3 ACTIVE UP 00:00:18 0 2.1
150.1.2.2 ACTIVE UP 00:00:20 0 2.1

Global Settings:
max-range-utilization percent 20 recv 0
mode route metric bgp local-pref 5000
mode route metric static tag 777
trace probe delay 1000
logging

Default Policy Settings:
backoff 90 180 90
delay relative 50
holddown 300
periodic 0
probe frequency 56
mode route control
mode monitor both
mode select-exit best
loss relative 10
jitter threshold 20
mos threshold 3.60 percent 30
unreachable relative 50
resolve delay priority 1 variance 1
resolve utilization priority 2 variance 1
resolve loss priority 3 variance 1
resolve range priority 4 variance 0

Learn Settings:
current state : RETRY
time remaining in current state : 12 seconds
throughput
delay
no inside bgp
no protocol
monitor-period 2
periodic-interval 1
aggregation-type prefix-length 32
prefixes 100
expire after time 720


cek Master :

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 155.1.13.3 to network 0.0.0.0

222.165.222.0/29 is subnetted, 1 subnets
O 222.165.222.72 [110/20010] via 155.1.12.2, 00:01:18, FastEthernet0/0
155.1.0.0/24 is subnetted, 2 subnets
C 155.1.12.0 is directly connected, FastEthernet0/0
C 155.1.13.0 is directly connected, FastEthernet0/1
150.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 150.1.1.0/24 is directly connected, Loopback0
O 150.1.3.3/32 [110/11] via 155.1.13.3, 00:01:18, FastEthernet0/1
O 150.1.2.2/32 [110/11] via 155.1.12.2, 00:01:20, FastEthernet0/0
202.72.212.0/28 is subnetted, 1 subnets
O 202.72.212.176 [110/205] via 155.1.13.3, 00:01:20, FastEthernet0/1
O*E1 0.0.0.0/0 [110/400] via 155.1.13.3, 00:01:20, FastEthernet0/1

cek lagi :
R1#traceroute 100.100.100.100 so lo0

Type escape sequence to abort.
Tracing the route to 100.100.100.100

1 155.1.13.3 16 msec 40 msec 84 msec
2 202.72.212.177 192 msec 44 msec 48 msec
3 200.1.1.1 128 msec * 80 msec

pertanyaan> kenapa lewat router 3 ya? itu kan primary, trus koq bisa primary ?
karena bandwitdhnya 512 alias lebih besar, cek this out :
di R3:
interface FastEthernet0/0
bandwidth 512
ip address 202.72.212.180 255.255.255.240
duplex auto
speed auto

sedangkan di R2 :
interface FastEthernet0/0
bandwidth 5
ip address 222.165.222.73 255.255.255.248
delay 1000000
duplex auto
speed auto

bandwitdhnya lebih kecil.



*Mar 1 01:42:14.795: %OER_MC-5-NOTICE: Prefix Learning STARTED

cek sla naik ok, kondisi OK*

R1#sh ip sla statistics

Round Trip Time (RTT) for Index 1
Latest RTT: 105 milliseconds
Latest operation start time: *01:47:45.515 UTC Fri Mar 1 2002
Latest operation return code: OK
RTT Values:
Number Of RTT: 799 RTT Min/Avg/Max: 5/105/267 milliseconds
Latency one-way time:
Number of Latency one-way Samples: 0
Source to Destination Latency one way Min/Avg/Max: 0/0/0 milliseconds
Destination to Source Latency one way Min/Avg/Max: 0/0/0 milliseconds
Jitter Time:
Number of SD Jitter Samples: 798
Number of DS Jitter Samples: 785
Source to Destination Jitter Min/Avg/Max: 0/15/96 milliseconds
Destination to Source Jitter Min/Avg/Max: 0/22/148 milliseconds
Packet Loss Values:
Loss Source to Destination: 0 Loss Destination to Source: 0
Out Of Sequence: 0 Tail Drop: 2
Packet Late Arrival: 0 Packet Skipped: 199
Voice Score Values:
Calculated Planning Impairment Factor (ICPIF): 12
MOS score: 4.03
Number of successes: 132
Number of failures: 2
Operation time to live: Forever



Round Trip Time (RTT) for Index 2
Latest RTT: 36 milliseconds
Latest operation start time: *01:48:24.535 UTC Fri Mar 1 2002
Latest operation return code: OK
Number of successes: 2786
Number of failures: 19
Operation time to live: Forever



Round Trip Time (RTT) for Index 3
Latest RTT: 164 milliseconds
Latest operation start time: *01:48:25.239 UTC Fri Mar 1 2002
Latest operation return code: OK
Number of successes: 1385
Number of failures: 2
Operation time to live: Forever

trus tiba2 keluar ini:

*Mar 1 01:48:59.299: %OER_MC-5-NOTICE: Discovered Exit for Prefix 100.100.100.100/32, BR 150.1.3.3, i/f Fa0/0

artinya bahwa prefix 100.100.100.100/32 akan di lewatkan 150.1.3.3 artinya ini R3!!! :)

tiba2 lagi eh:

*Mar 1 01:49:41.247: %OER_MC-5-NOTICE: Route changed Prefix 100.100.100.100/32, BR 150.1.2.2, i/f Fa0/0, Reason Delay, OOP Reason Timer Expired

lihat alasannya? ininih = Reason Delay, OOP Reason Timer Expired

koq delay, ya iyalah, lihat interface f0/0 di R3 :

R1#traceroute 100.100.100.100 so lo0

Type escape sequence to abort.
Tracing the route to 100.100.100.100

1 155.1.12.2 44 msec 116 msec 16 msec
2 222.165.222.78 168 msec 72 msec 104 msec
3 200.1.1.1 88 msec * 332 msec
R1#traceroute 100.100.100.100 so lo0

Type escape sequence to abort.
Tracing the route to 100.100.100.100

1 155.1.12.2 16 msec 16 msec 176 msec
2 222.165.222.78 156 msec 216 msec 120 msec
3 200.1.1.1 256 msec
*Mar 1 01:56:57.199: %OER_MC-5-NOTICE: Route changed Prefix 100.100.100.100/32, BR 150.1.3.3, i/f Fa0/0, Reason Unreachable, OOP Reason Utilization * 284 msec
R1#traceroute 100.100.100.100 so lo0

Type escape sequence to abort.
Tracing the route to 100.100.100.100

1 155.1.13.3 260 msec 224 msec 204 msec
2 202.72.212.177 160 msec 136 msec 204 msec
3 200.1.1.1 212 msec * 196 msec
R1#traceroute 100.100.100.100 so lo0

Lihat pergantian di atas, nunggu agak lama juga, koq gak bisa cepat yah? apa karena processor gua udah 98% ya? mungkin jika di perangkat langsung gak bakal gini :(
ok C U...

IP Access-list Reflexive

Berikut konfigurasi ip reflexive :



ip access-list extended infilter
permit icmp any any reflect tcpfilter
ip access-list extended outfilter
evaluate tcpfilter
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip access-group infilter in
ip access-group outfilter out

duplex auto
speed auto
!

Result :

client#ping 2.2.2.2 re 10

Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 12/45/80 ms
client#

sedangkan kebalikanya tidak bisa :

r2#ping 192.168.1.2 so lo 0 re 1000

Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
Packet sent with a source address of 2.2.2.2
U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.

Rabu, 12 Oktober 2011

IP SLA - Failover 2 link

Saat kita memiliki 2 link internet ke ISP1 dan ISP2 kita pasti berpikir kenapa tidak dibikin failover, saat ISP link 1 mati maka link internet akan berpindah ke link ISP 2.

Berikut cara agar hal tersebut terwujud :



Config hanya ada di R1:

hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
archive
log config
hidekeys
!
!
track 1 rtr 1 reachability
!
!
!
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 12.12.12.2 track 1
ip route 0.0.0.0 0.0.0.0 13.13.13.3 10
!
!
no ip http server
no ip http secure-server
!
ip sla 1
icmp-echo 12.12.12.2 source-interface FastEthernet1/0
timeout 500
frequency 3
ip sla schedule 1 life forever start-time now


------------------------------------------------

logging :

*Mar 1 00:48:28.791: %TRACKING-5-STATE: 1 rtr 1 reachability Down->Up

R1#sh ip sla statistics

Round Trip Time (RTT) for Index 1
Latest RTT: 20 milliseconds
Latest operation start time: *00:48:57.755 UTC Fri Mar 1 2002
Latest operation return code: OK
Number of successes: 123
Number of failures: 798
Operation time to live: Forever

-----------------------------------------------------
ping ke 4.4.4.4 (internet)

R5#ping 4.4.4.4 re 10000

Type escape sequence to abort.
Sending 10000, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.
Success rate is 96 percent (29/30), round-trip min/avg/max = 48/64/92 ms


traceroute 4.4.4.4 :

Type escape sequence to abort.
Tracing the route to 4.4.4.4

1 192.168.1.1 44 msec 64 msec 16 msec
2 12.12.12.2 48 msec 16 msec 72 msec ------------> melalui ISP 1 Primary (Normal)
3 24.24.24.4 128 msec * 72 msec

coba kita shut interface primary isp arah ke router cust :

R2(config)#int f0/1
R2(config-if)#sh
R2(config-if)#
*Mar 1 01:28:19.115: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
*Mar 1 01:28:20.115: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

Lihat di Router Cust yg di setting SLA :

*Mar 1 00:51:38.791: %TRACKING-5-STATE: 1 rtr 1 reachability Up->Down

R5#ping 4.4.4.4 re 10000

Type escape sequence to abort.
Sending 10000, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!....!!!
!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 97 percent (188/192), round-trip min/avg/max = 44/66/112 ms

Lihat router sempat rto sebentar dan lanjut kembali begitu SLA beraksi :)
Dan akan kembali normal begitu interface kita no shut kembali.

Senin, 10 Oktober 2011

MPLS TE OSPF load share


Berikut MPLS TE dengan OSPF dan tunnel



hostname R1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel2
ip unnumbered Loopback0
no clns route-cache
tunnel destination 5.5.5.5
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name R1-R2-R5
tunnel mpls traffic-eng load-share 10
!
interface Tunnel3
ip unnumbered Loopback0
no clns route-cache
tunnel destination 5.5.5.5
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name R1-R3-R5
tunnel mpls traffic-eng load-share 20
!
interface Tunnel4
ip unnumbered Loopback0
no clns route-cache
tunnel destination 5.5.5.5
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name R1-R4-R5
tunnel mpls traffic-eng load-share 30
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
duplex half
no clns route-cache
!
interface Serial1/0
ip address 12.12.12.1 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/1
ip address 13.13.13.1 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/2
ip address 14.14.14.1 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
ip explicit-path name R1-R2-R5 enable
next-address 12.12.12.2
next-address 25.25.25.5
next-address 5.5.5.5
!
ip explicit-path name R1-R3-R5 enable
next-address 13.13.13.3
next-address 35.35.35.5
next-address 5.5.5.5
!
ip explicit-path name R1-R4-R5 enable
next-address 14.14.14.4
next-address 45.45.45.4
next-address 5.5.5.5
!
!
!
control-plane
!
!
dial-peer cor custom

R2 :
hostname R2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface Serial1/0
ip address 12.12.12.2 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/1
ip address 25.25.25.2 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
dial-peer cor custom

R3:

hostname R3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface Serial1/0
ip address 13.13.13.3 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/1
ip address 35.35.35.3 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
dial-peer cor custom


R4:

hostname R4
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface Serial1/0
ip address 14.14.14.4 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/1
ip address 45.45.45.4 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
dial-peer cor custom

R5 :

hostname R5
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface Serial1/0
ip address 25.25.25.5 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/1
ip address 35.35.35.5 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/2
ip address 45.45.45.5 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
no clns route-cache
ip rsvp bandwidth
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
dial-peer cor custom


Capt:

sh mpls traffic-eng tunnels

Name: R1_t2 (Tunnel2) Destination: 5.5.5.5
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit R1-R2-R5 (Basis for Setup, path weight 128)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 10
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : Serial1/0, 23
RSVP Signalling Info:
Src 1.1.1.1, Dst 5.5.5.5, Tun_Id 2, Tun_Instance 4
RSVP Path Info:
My Address: 12.12.12.1
Explicit Route: 12.12.12.2 25.25.25.5 5.5.5.5
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 1 hours, 48 minutes
Time since path change: 1 hours, 38 minutes
Number of LSP IDs (Tun_Instances) used: 4
Current LSP:
Uptime: 1 hours, 38 minutes
Prior LSP:
ID: path option 1 [3]
Removal Trigger: configuration changed

Name: R1_t3 (Tunnel3) Destination: 5.5.5.5
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit R1-R3-R5 (Basis for Setup, path weight 128)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 20
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : Serial1/1, 23
RSVP Signalling Info:
Src 1.1.1.1, Dst 5.5.5.5, Tun_Id 3, Tun_Instance 4
RSVP Path Info:
My Address: 13.13.13.1
Explicit Route: 13.13.13.3 35.35.35.5 5.5.5.5
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 1 hours, 48 minutes
Time since path change: 1 hours, 38 minutes
Number of LSP IDs (Tun_Instances) used: 4
Current LSP:
Uptime: 1 hours, 38 minutes
Prior LSP:
ID: path option 1 [3]
Removal Trigger: configuration changed

Name: R1_t4 (Tunnel4) Destination: 5.5.5.5
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit R1-R4-R5 (Basis for Setup, path weight 128)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 30
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : Serial1/2, 24
RSVP Signalling Info:
Src 1.1.1.1, Dst 5.5.5.5, Tun_Id 4, Tun_Instance 19
RSVP Path Info:
My Address: 14.14.14.1
Explicit Route: 14.14.14.4 45.45.45.5 5.5.5.5
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 1 hours, 48 minutes
Time since path change: 36 minutes, 42 seconds
Number of LSP IDs (Tun_Instances) used: 19
Current LSP:
Uptime: 36 minutes, 42 seconds
Prior LSP:
ID: path option 1 [4]
Removal Trigger: label reservation removed

MPLS TE

MPLS TE (Traffic Engineering)

Dah lama juga mau coba tapi gak kesampaian2 teyuss.
Dalam MPLS kita butuh memberdayakan link agar tidak terjadi penumpukan dan pemilihan rute terbaik dari satu source ke destination.

berikut TE di MPLS yg dapat mencontohkan TE sederhana yg dapat dan mudah di mengerti,
sengaja mengunakan ISIS nanti akan menggunakan OSPF buat lab ke 2 dan ini dynamic route ya..



PE1 :
hostname PE1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
interface Tunnel13
ip unnumbered Loopback1
no clns route-cache
tunnel destination 3.3.3.3
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 1 dynamic
!
interface Loopback0
ip address 150.1.1.1 255.255.255.255
no clns route-cache
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface FastEthernet1/0
ip address 12.12.12.1 255.255.255.0
ip router isis
speed auto
duplex auto
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
no clns route-cache
!
router isis
net 49.0123.0000.0000.0001.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
passive-interface Loopback1
mpls traffic-eng router-id Loopback1
mpls traffic-eng level-2
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom


PE2 :

hostname PE2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
interface Loopback0
ip address 150.1.2.2 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface FastEthernet1/0
ip address 12.12.12.2 255.255.255.0
ip router isis
speed auto
duplex auto
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
no clns route-cache
!
interface FastEthernet2/0
ip address 23.23.23.2 255.255.255.0
ip router isis
speed auto
duplex auto
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
no clns route-cache
!
router isis
net 49.0123.0000.0000.0002.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom

PE3:

hostname PE3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
!
interface Loopback0
ip address 150.1.3.3 255.255.255.255
no clns route-cache
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface FastEthernet2/0
ip address 23.23.23.3 255.255.255.0
ip router isis
speed auto
duplex auto
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
no clns route-cache
!
router isis
net 49.0123.0000.0000.0003.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
passive-interface Loopback1
mpls traffic-eng router-id Loopback1
mpls traffic-eng level-2
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom


TE di MPLS selalu menggunakan link-state dan RSVP. karena di link-state terdapat Type-Length-Values (TLVs); OSPF menggunakan type 10 Link-State Advertisements (Opaque LSAs).

PE1#sh mpls traffic-eng tunnels

Name: PE1_t13 (Tunnel13) Destination: 3.3.3.3
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type dynamic (Basis for Setup, path weight 20)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: disabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: dynamic path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : FastEthernet1/0, 21
RSVP Signalling Info:
Src 1.1.1.1, Dst 3.3.3.3, Tun_Id 13, Tun_Instance 32
RSVP Path Info:
My Address: 12.12.12.1
Explicit Route: 12.12.12.2 23.23.23.2 23.23.23.3 3.3.3.3
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 2 hours, 7 minutes
Time since path change: 31 minutes, 34 seconds
Number of LSP IDs (Tun_Instances) used: 32
Current LSP:
Uptime: 31 minutes, 34 seconds
Prior LSP:
ID: path option 1 [30]
Removal Trigger: configuration changed

Rabu, 05 Oktober 2011

LAB

Frame-Relay Back to Back
Tanpa Frame Relay Switch

R1 s1/0 ----Framerelay----s1/0 R2


hostname R1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface Serial1/0
ip address 10.10.10.1 255.255.255.0
encapsulation frame-relay
no keepalive
serial restart-delay 0
frame-relay map ip 10.10.10.2 102 broadcast
no frame-relay inverse-arp IP 201
frame-relay local-dlci 201
no clns route-cache
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
ip classless
!
no ip http server
!
!
!
!
!
!
control-plane
!

--------------------------------------------
--------------------------------------------

hostname R2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface Serial1/0
ip address 10.10.10.2 255.255.255.0
encapsulation frame-relay
no keepalive
serial restart-delay 0
frame-relay map ip 10.10.10.1 201 broadcast
no frame-relay inverse-arp IP 102
frame-relay local-dlci 102
no clns route-cache
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
ip classless
!
no ip http server
!
!
!
!
!
!
control-plane
!
!
dial-peer cor custom
!