Senin, 10 Oktober 2011

MPLS TE

MPLS TE (Traffic Engineering)

Dah lama juga mau coba tapi gak kesampaian2 teyuss.
Dalam MPLS kita butuh memberdayakan link agar tidak terjadi penumpukan dan pemilihan rute terbaik dari satu source ke destination.

berikut TE di MPLS yg dapat mencontohkan TE sederhana yg dapat dan mudah di mengerti,
sengaja mengunakan ISIS nanti akan menggunakan OSPF buat lab ke 2 dan ini dynamic route ya..



PE1 :
hostname PE1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
interface Tunnel13
ip unnumbered Loopback1
no clns route-cache
tunnel destination 3.3.3.3
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 1 dynamic
!
interface Loopback0
ip address 150.1.1.1 255.255.255.255
no clns route-cache
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface FastEthernet1/0
ip address 12.12.12.1 255.255.255.0
ip router isis
speed auto
duplex auto
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
no clns route-cache
!
router isis
net 49.0123.0000.0000.0001.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
passive-interface Loopback1
mpls traffic-eng router-id Loopback1
mpls traffic-eng level-2
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom


PE2 :

hostname PE2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
interface Loopback0
ip address 150.1.2.2 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface FastEthernet1/0
ip address 12.12.12.2 255.255.255.0
ip router isis
speed auto
duplex auto
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
no clns route-cache
!
interface FastEthernet2/0
ip address 23.23.23.2 255.255.255.0
ip router isis
speed auto
duplex auto
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
no clns route-cache
!
router isis
net 49.0123.0000.0000.0002.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom

PE3:

hostname PE3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!
!
interface Loopback0
ip address 150.1.3.3 255.255.255.255
no clns route-cache
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface FastEthernet2/0
ip address 23.23.23.3 255.255.255.0
ip router isis
speed auto
duplex auto
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
no clns route-cache
!
router isis
net 49.0123.0000.0000.0003.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
passive-interface Loopback1
mpls traffic-eng router-id Loopback1
mpls traffic-eng level-2
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom


TE di MPLS selalu menggunakan link-state dan RSVP. karena di link-state terdapat Type-Length-Values (TLVs); OSPF menggunakan type 10 Link-State Advertisements (Opaque LSAs).

PE1#sh mpls traffic-eng tunnels

Name: PE1_t13 (Tunnel13) Destination: 3.3.3.3
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type dynamic (Basis for Setup, path weight 20)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: disabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: dynamic path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : FastEthernet1/0, 21
RSVP Signalling Info:
Src 1.1.1.1, Dst 3.3.3.3, Tun_Id 13, Tun_Instance 32
RSVP Path Info:
My Address: 12.12.12.1
Explicit Route: 12.12.12.2 23.23.23.2 23.23.23.3 3.3.3.3
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 2 hours, 7 minutes
Time since path change: 31 minutes, 34 seconds
Number of LSP IDs (Tun_Instances) used: 32
Current LSP:
Uptime: 31 minutes, 34 seconds
Prior LSP:
ID: path option 1 [30]
Removal Trigger: configuration changed

Tidak ada komentar: