Minggu, 24 April 2011

MPLS + BGP + As Over-ride

Jika customer membuthkan BGP advertise di sisi mereka, maka dalam MPLS kita akan mengenal istilah OVERRIDE AS:

Gambaran paling bodohnya :)
Cust(CE)BGP-------(BGP AS Override)PE-----P------PE(BGP AS Override)-------BGP(CE)Cust

Berikut konfigurasi CE:
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
interface Loopback0
ip address 77.77.77.7 255.255.255.0
!
interface FastEthernet0/0
ip address 100.100.100.7 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 65501
no synchronization
bgp log-neighbor-changes
network 77.77.77.0 mask 255.255.255.0
network 100.100.100.0 mask 255.255.255.0
neighbor 100.100.100.1 remote-as 234
neighbor 100.100.100.1 soft-reconfiguration inbound
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane

Dan konfigurasi PE:

!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf ADIRA
rd 200:1
route-target export 200:1
route-target import 200:1
!
ip vrf XL
rd 100:1
route-target export 100:1
route-target import 100:1
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
no ip address
speed 100
full-duplex
!
interface FastEthernet0/1.100
encapsulation dot1Q 100
ip vrf forwarding XL
ip address 100.100.100.1 255.255.255.0
!
interface FastEthernet0/1.200
encapsulation dot1Q 200
ip vrf forwarding ADIRA
ip address 200.200.200.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 23.23.23.3 0.0.0.0 area 0
!
router bgp 234
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 234
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf XL
redistribute connected
neighbor 100.100.100.7 remote-as 65501
neighbor 100.100.100.7 activate
neighbor 100.100.100.7 as-override
no synchronization
exit-address-family
!
address-family ipv4 vrf ADIRA
redistribute connected
no synchronization
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
mpls ldp router-id Loopback0
!
!
control-plane

-----------------------------------

R3#sh ip bgp vpnv4 all
BGP table version is 15, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf XL)
*>i10.10.10.0/24 4.4.4.4 0 100 0 ?
*> 77.77.77.0/24 100.100.100.7 0 0 65501 i
*>i99.99.99.0/24 4.4.4.4 0 100 0 65501 i
* 100.100.100.0/24 100.100.100.7 0 0 65501 i
*> 0.0.0.0 0 32768 ?
Route Distinguisher: 200:1 (default for vrf ADIRA)
*>i20.20.20.0/24 4.4.4.4 0 100 0 ?
*> 200.200.200.0 0.0.0.0 0 32768 ?

nemukan prefix dari cust di CE sebrang? hehe :)
jadi AS Override ini digunakan karena BGP prevent looping kalau sebuah AS bertemu AS yang sama kembali. seperti contoh di atas:

AS65501(CE)---->AS234(P)----->AS65501(CE) AS yang sama bertemu dengan AS yg sama kembali (Loop)

Tidak ada komentar: